TeamViewer Forum

General Category => Teamviewer for Linux => Topic started by: manualdidact on December 29, 2016, 09:53:42 AM

Title: Teamviewer 12 on Fedora 25, control but no screen updates
Post by: manualdidact on December 29, 2016, 09:53:42 AM
So I've just done a clean install of Fedora 25 on a Thinkpad T410, and have installed Teamviewer and little else. Of course out of the box this doesn't work since Fedora 25 uses Wayland by default. For some reason this manifests in the incorrect error message about not being able to connect, which isn't actually the problem at all. I've worked around this problem by switching to using Xorg instead of Wayland in /etc/gdm/custom.conf.

So, I tried connecting to this computer from a Windows computer, and from an Android client, and both show the same behavior:


The only difference between Android and Windows clients is that the Windows client will flicker the little Teamviewer session window, as it can't decide whether it should be visible or not, though it's been put away on Bob and so shouldn't be visible.

Clearly, Alice is just inventing its own version of what Bob should look like based on how it was first visible at the first connection attempt, but gets no further information about what Bob is actually doing.

I'd appreciate an assist, maybe some things to try...?

For what it's worth, the Thinkpad is running Intel graphics on a Core I5 M520 CPU. The Fedora 25 installation is essentially out-of-the-box, except for the switch to Xorg.

Thanks!