Author Topic: sending key combination  (Read 5899 times)

TheFlipside

  • Newbie
  • *
  • Posts: 1
sending key combination
« on: April 19, 2011, 02:21:38 AM »
Hello there,

I have a little problem. I'm managing a couple of Linux computers running Ubuntu 10.04 with TeamViewer 6 from my Windows 7 32-bit PC. Its all working well, I have set the Linux machines to login automatically and TeamViewer to launch automatically, this all works well.
My problem is though I wanna send the key combination CTRL-C to a running terminal session on these Ubuntu machines at the end of the day to stop a script but it's not working via TeamViewer.
The odd thing is when I launch a new terminal i can close it with CTRL-D  ???
If it matters I'm running version 6.0.10511 on my Windows machine and on the Ubuntu machines it's 6.0.9224.
Does anyone have a tip or clue about this issue?

Thanks

EDIT:
I checked out UltraVNC and I can connect to my Linux machines after I installed x11vnc on them. It's working out nicely and it has file fransfer too AND i figured out it can handle all key combinations I always wanted, like CTRL-C so it looks like I will use this program from now on. That's actually a bit sad because TeamViewer never disappointed me. I wonder if anyone here has an opinion on this.
« Last Edit: April 23, 2011, 05:33:45 AM by TheFlipside »

GazRockK

  • Newbie
  • *
  • Posts: 1
Re: sending key combination
« Reply #1 on: July 28, 2011, 11:05:24 PM »
If I may.. how did you get teamviewer running on startup ?
(command line please)

anoushg

  • Newbie
  • *
  • Posts: 2
Re: sending key combination
« Reply #2 on: September 02, 2011, 03:12:42 AM »
here is a way to make it start automaticaly :
you go on the autostart of your user, you add a file called teamviewer6.desktop, make it exacutable, and put inside this text :
[Desktop Entry]
Type=Application
Encoding=UTF-8
Version=1.0
Name=teamviewer
Name[en_US]=teamviewer
Exec=teamviewer
X-GNOME-Autostart-enabled=true

here the commande line to do :
touch /home/user/.conf/autostart/teamviewer6.desktop
echo [Desktop Entry] >> /home/user/.conf/autostart/teamviewer6.desktop
echo Type=Application >> /home/user/.conf/autostart/teamviewer6.desktop
echo Encoding=UTF-8 >> /home/user/.conf/autostart/teamviewer6.desktop
echo Version=1.0 >> /home/user/.conf/autostart/teamviewer6.desktop
echo Name=teamviewer >> /home/user/.conf/autostart/teamviewer6.desktop
echo Name[en_US]=teamviewer >> /home/user/.conf/autostart/teamviewer6.desktop
echo Exec=teamviewer >> /home/user/.conf/autostart/teamviewer6.desktop
echo X-GNOME-Autostart-enabled=true >> /home/user/.conf/autostart/teamviewer6.desktop

you make the file executable this way :
chmod 777 /home/user/.conf/autostart/teamviewer6.desktop

should work

Anoush