Author Topic: "WaitforConnectFailed" ?  (Read 10739 times)

PeteCress

  • Newbie
  • *
  • Posts: 20
"WaitforConnectFailed" ?
« on: October 13, 2013, 05:07:46 PM »
Remote PC gets turned on and, I guess, somehow gets out to the internet because my instance of TeamViewer lists it as active/available on Computers & Contacts | MyPartners.

But, at some point, the user reports that they "cannot get to the internet".

When I try to connect to that PC, my instance of TeamViewer throws:

---------------------------------
No connection to partner!

Partner did not connect to router.

Error Code: WaitforConnectFailed
----------------------------------

The statement "Partner did not connect to router" sounds awfuly specific to me... but I have no clue what it implies besides that the remote PC somehow lost it's connection.  OTOH, how is the TeamViewer server deciding that that PC is available?

Can anybody suggest what might be going on?

Admin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 379
Re: "WaitforConnectFailed" ?
« Reply #1 on: October 14, 2013, 09:34:50 AM »
does the remote computer go into a "sleep" mode?
can someone reboot the remote system or take it out of sleep?

matt

  • Hero Member
  • *****
  • Posts: 545
Re: "WaitforConnectFailed" ?
« Reply #2 on: October 14, 2013, 11:18:17 PM »
The statement "Partner did not connect to router" sounds awfuly specific to me... but I have no clue what it implies besides that the remote PC somehow lost it's connection.  OTOH, how is the TeamViewer server deciding that that PC is available?
Teamviewer server gets regular 'pings' from all connected computers.

An internet connection dropping out will cause the 'pings' to not work.

OFark

  • Newbie
  • *
  • Posts: 1
Re: "WaitforConnectFailed" ?
« Reply #3 on: April 24, 2014, 06:48:45 AM »
I get the same problem, on a local machine, 3 meters from me, with no firewall active, just after I've disconnected and tried to reconnect, on the same switch.

I also have problems connecting to a remote machine, but I get no error, it just continually says "connecting...".

Neither the machine near me nor the remote machine show any signs of an error, according to Teamviewer they are connected and all is good.

Incidentally I tried to remotely restart the remote computer and all services disappeared from the internet except Teamviewer. When I got to it's location it was telling me "Teamviewer minimised" was stopping Windows from shutting down, did I want to force close. VERY VERY Annoying.

PeteCress

  • Newbie
  • *
  • Posts: 20
Re: "WaitforConnectFailed" ?
« Reply #4 on: October 13, 2014, 06:38:01 AM »
I get the same problem, on a local machine, 3 meters from me, with no firewall active, just after I've disconnected and tried to reconnect, on the same switch.

I also have problems connecting to a remote machine, but I get no error, it just continually says "connecting...".

Neither the machine near me nor the remote machine show any signs of an error, according to Teamviewer they are connected and all is good.

Incidentally I tried to remotely restart the remote computer and all services disappeared from the internet except Teamviewer. When I got to it's location it was telling me "Teamviewer minimised" was stopping Windows from shutting down, did I want to force close. VERY VERY Annoying.

Bump!....

I'm back to a similar situation, only with a different computer:  one that is running an IP camera server about 90 miles from here.

TeamViewer's "Computers & Contacts" shows it as being online... it responds to Ping... The IP cam server app on it is serving up the cams....

First thing that I think of is that TeamViewer has abended on that PC... but if that is the case, why is it showing up on Computers & Contacts as being online?

Can anybody elucidate?