Author Topic: Notes about "not ready please check connection" in Linux  (Read 27795 times)

mediaklan

  • Newbie
  • *
  • Posts: 1
Notes about "not ready please check connection" in Linux
« on: March 17, 2014, 07:29:09 AM »
Hi you all !
I came across some quick/dirty fixes for this problem in Linux, with different distributions, when Teamviewer is unable to recognize your internet connection and use it accordingly.
Here's some clues that may or may NOT work for your (particular) setup, you're responsible for whar you're doing bla bla bla ...
1. Using Fedora 20, the teamviewer rpm installs in /opt/teamviewer9. Normally, that should be fine like this. However, running teamviewer as a normal user or root didn't work for me either way : well, teamviewer's running alright, but both method end up with lazy "please check your f... connection". So i checked this folder and find out that some files had full user rights, and others only root. So i
Code: [Select]
chmod -Rf 770 all files (you know it is not recommanded at all, right ?) and voilĂ  ! Done. A better way of course should be to check each files and act accordingly.
2. On last Ubuntu (well, xubuntu, but it should be the same ?), problem was solved using a lot harder fix. And unfortunately, I can't for the life of me retrieve exactly the particular fix I used, but nevertheless, it was something related to wine. And specifically with the way Wine is checking connection. I only remember opening regedit (using wine teamviewer path as wine prefix : /path_to/teamviewer9/profile/) and change something in there ... but sorry, don't remember what and can't retrieve this.
Finally, another method that worked (for me) in ArchLinux was to dropped Linux version, using Windows one with Wine. As the problem still occured (getting right on my nerves again), I end up using chmod only for the exe, and it worked. Wine didn't even complain (which is strange, 'cause I was pretty sure Wine don't really appreciate that we mess up with user rights in program files folder).   
VoilĂ  ! I'm not sure if any of this will actually help you, but I think that could give some of you something to start with.

jmward

  • Newbie
  • *
  • Posts: 1
Re: Notes about "not ready please check connection" in Linux
« Reply #1 on: August 08, 2014, 04:51:36 AM »
Thanks very much for this.  I have been following your suggestions the logical way, i.e. making random changes in file and directory permissions and uninstalling and reinstalling TeamViewer 8 and 9, including MultiArch versions.  Something has certainly worked, but because of my methodical approach, I'm not sure what; the PC now boots up with TeamViewer ready to go.  Messing about with the TeamViewer daemon, which is really hard to shut down, seems to be problematic; it's best to install and then reboot and let the daemon do its stuff.  Looking at the log files, there seem to be an issue with the file and directory permissions tracking through a link from /opt/teamviewer9/config into the user's home directory.  I have basically changed ownership and permissions so that owner and root can do anything to config files accessed this way, and that seems to be the key difference.

Once it's working, I'm surprised just how good it is!

 

anything