Author Topic: Blue Screen on "MY" PC when connecting to remote Windows using VMware vSphere  (Read 14531 times)


  • Newbie
  • *
  • Posts: 2
Hi.  This sounds crazy, it makes no sense at all.   I am trying to evaluate TeamViewer to determine if it is the right solution. So far, it's proved to be a little frustrating.  I access remote systems, generally virtualized, and in a lot of cases once I remote in, I launch the VMWare vSphere client to do various tasks for servers that I support.

What happens is that "MY" system that I am connecting from gets a Blue Screen of Death. It is running Windows 7 X64.  Teamviewer version 9.0.28223

The BlueScreen occurs randomly when I am working within a Remote session and using the vSphere client.  I have paid close attention and it ONLY happens when I am actively working inside the vSphere Client. I never crash when NOT using vSphere.

Things to note:

- The Remote PC doesn't crash. My Local PC does.
- I thought maybe it was a driver or other issue on my system. However I have had this happen on a completely different system/vendor architecture.  My main system is a custom built PC but I also crashed my laptop which is an HP brand.  Both Running Win7 x64. But the hardware between both systems is drastically different.

- The error is in the WIN2K.sys module.  And it's always the same error.
- Sometimes after I crash, then reboot, reconnect.. it crashes again within a couple minutes doing the same tasks.
- My systems NEVER bluescreen ever. Only when connected to Teamviewer and ONLY when using vsphere client on the remote system.
- I have attempted to remove antivirus and other services to keep system minimal as possible and I have crashed under all scenarios.
- I am a seasoned IT Professional, not a noob.

I was optimistic that Teamviewer would be a good solution, however this is a showstopper for me.

Error is basically:

STOP: 0x00000050

Any thoughts or advice? Has anybody else run into this?


  • Administrator
  • Sr. Member
  • *****
  • Posts: 454
i would definitely start a support ticket and also post the their facebook page.
Links in my sig and also at the top of the page.
sounds like you may have discovered a bug.


  • Newbie
  • *
  • Posts: 3
If you have the VPN option checked during install remove that


  • Newbie
  • *
  • Posts: 1
Sorry for the bump but I get the exact same problem (with the exact same BSOD Cause, the non paged area one). I've noticed it only ever does it for me when I am connected to a remote Mac running teamviewer. I also noticed that the teamviewer remote control app for iOS also crashes in the same situation so I definitely think it's a bug in their code.


  • Newbie
  • *
  • Posts: 23
Start a support ticket. And if you can, include the minidump that Windows writes for that bluescreen and the TeamViewer logfiles.

You could also try to disable the clipboard synchronization or remote audio.


  • Newbie
  • *
  • Posts: 1
I have the same problem, but a little bit different scenario. I am connecting from Win7 64bit to a Win8.1 that is running OS X in vmWare Player. Blue screen every time. Even TeamViewer client on Windows Phone crashes.


  • Newbie
  • *
  • Posts: 1
I have the same problem, but a little bit different scenario. I am connecting from Win7 64bit to a Win8.1 that is running OS X in vmWare Player. Blue screen every time. Even TeamViewer client on Windows Phone crashes.

Same exact issue! I contacted TeamViewer support but they refused to help me at all. This was their response: "We only provide support for our product, which is TeamViewer and do not offer services related to computer home repair."


  • Administrator
  • Sr. Member
  • *****
  • Posts: 454
i would reply and remind them it only happens when using teamviewer.


  • Newbie
  • *
  • Posts: 1
I would like to second what the person originally mentioned about it crashing during VmWare use when you are dialed in on the remote computer.

Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arg1: fffff900c283b000, memory referenced.
Arg2: 0000000000000000, value 0 = read operation, 1 = write operation.
Arg3: fffff96000115f9a, If non-zero, the instruction address which referenced the bad memory
Arg4: 0000000000000000, (reserved)

Debugging Details:

READ_ADDRESS:  fffff900c283b000 Paged session pool

fffff960`00115f9a 4c8b540af8              mov     r10,qword ptr [rdx+rcx-8]


IMAGE_NAME:  win32k.sys



FAULTING_MODULE: fffff96000050000 win32k



PROCESS_NAME:  TeamViewer.exe


ANALYSIS_VERSION: 6.3.9600.17237 (debuggers(dbg).140716-0327) x86fre


  • Newbie
  • *
  • Posts: 2
I am posting a follow up to this issue.

As suggested initially, I contacted TeamViewer support and went through an extremely time consuming process of duplicating the issue for them on Video so that they could see exactly what was happening. Also, to note, I originally had this problem with Teamviewer 9.

*Note * I was working with a front line guy and it was obvious he was just a gobetween guy and that was also frustrating.. But After a few weeks of back and forth and hours of internal testing, resending stuff for them to look at, etc..  The guy came back and told me it was a "KNOWN ISSUE".

This is the exact Email I received:

"Thank you for getting back to us.  We got some news from our developers that this is unfortunately a known problem in the current version. Our developers are already working on a solution and this will be fixed as soon as possible.  We are really sorry about the inconvenience.  If you have any further questions, please feel free to contact us."

Ticket number is #1440133 if anybody cares.

And for reference the same bug still exists in Teamviewer 10.0.36897 and I am extremely disappointed.  It is unusable. I don't have time to spend troubleshooting their issue, I work around it of sorts by using a VM on my workstation to connect to vSphere. That way when it blue screens it only affects the VM, not my entire workstation.


  • Newbie
  • *
  • Posts: 1
I found this thread(the only one) after experiencing the exact same issue. (Local PC BSOD when accessing remote PC via TeamViewer and only when using vSphere Client on the remote PC)
And this has happened on Windows 7 and Windows 10 local PCs with TeamViewer 11.

Doesn't happen all the time but enough to get annoying. So looks like this 'known issue' is still ongoing.

My TeamViewer is licensed through Maxfocus so I'll log a support with them.


  • Newbie
  • *
  • Posts: 1
Re: Blue Screen on "MY" PC when connecting to remote Windows using VMware vSphere
« Reply #11 on: September 25, 2016, 11:52:24 AM »
I recently set up a MAC VM on one of my machines using VMWare Workstation Player 12 and then remoted in to it using the Teamviewer iPhone app.  The app was crashing on me, but I assumed it was a connection issue.

I went to my desktop and tried again and got BSODs on my machine (the same one mentioned here).  Did some googling and found this thing.  Seems that there is indeed an issue.  I've opened a support ticket as well.  If they know it's a bug, it needs to be better documented and it shouldn't take two years to fix it.
« Last Edit: September 25, 2016, 11:55:50 AM by Raptor2213 »


  • Newbie
  • *
  • Posts: 1
Still happening 3 years later...

2...3 times until I figured it out - teamviewer 12.0 causing BSOD with win32k.sys

Win 10 Running VM workstation 12 with Guest mac os 10.12 (everything is okay on this end)

Win 7 with TeamViewer into the win 10 machine with VMware (this machine BSOD)


  • Newbie
  • *
  • Posts: 2
Damn, summer of 2017, and it still happens...

Windows Server 2012 Host, connecting via Teamviewer 12 to Windows 10 Host. Windows 10 hosts a VmPlayer VM with OSX 10.12.
Dump File         : 072117-7035-01.dmp
Crash Time        : 21.07.2017 10:12:19
Bug Check Code    : 0x00000050
Parameter 1       : fffff901`0279f000
Parameter 2       : 00000000`00000000
Parameter 3       : fffff960`001875a0
Parameter 4       : 00000000`00000000
Caused By Driver  : ntoskrnl.exe
Caused By Address : ntoskrnl.exe+7b040
File Description  : NT Kernel & System
Product Name      : Microsoft® Windows® Operating System
Company           : Microsoft Corporation
File Version      : 6.2.9200.16384 (win8_rtm.120725-1247)
Processor         : x64
Crash Address     : ntoskrnl.exe+7b040
Stack Address 1   :
Stack Address 2   :
Stack Address 3   :
Computer Name     :
Full Path         : C:\Windows\Minidump\072117-7035-01.dmp
Processors Count  : 4
Major Version     : 15
Minor Version     : 9200
Dump File Size    : 310.112
Dump File Time    : 21.07.2017 10:13:32

It kills my Win 2012 Host every freakin time... Tried it on Windows 10 to Windows 10 Connection as well, with the same result.

I will look for other remote Solutions. This won`t ever be solved!
« Last Edit: July 21, 2017, 01:37:57 AM by Lynx »