Author Topic: Teamviewer 11 no unattended access without login first  (Read 3557 times)

MarkBrading

  • Newbie
  • *
  • Posts: 1
Teamviewer 11 no unattended access without login first
« on: January 16, 2016, 05:04:20 AM »
Hi all,

I have been using TeamViewer 10 to remote access between my Linux mint 17.2 machines without problems.   I have set up unattended access so that I am able to access them remotely without logging in and this has been working fine until I upgraded to TeamViewer 11.

My problem is that in v11 I have to login on the remote machine first before TeamViewer allows unattended access to that machine.  On the client machine, which is trying to access the remote machine, the TeamViewer "Computers & Contacts" shows that the remote machine is offline until I have logged in.

I have checked that the TeamViewer daemon is running on the remote machine prior to login by using a ssh login to verify.

Please can someone help?

Regards, Mark

czarak

  • Newbie
  • *
  • Posts: 1
Re: Teamviewer 11 no unattended access without login first
« Reply #1 on: March 12, 2016, 08:15:23 AM »
Same problem, any ideas?

mangotree

  • Newbie
  • *
  • Posts: 1
Re: Teamviewer 11 no unattended access without login first
« Reply #2 on: March 20, 2016, 08:51:07 AM »
I have the same problem too. It's only since TeamV 11 that it started.

I have tried everything via SSH, daemon start, etc etc,  but it does'nt connect to the Teamviwer Server until I actually login to my Ubuntu desktop.

When I try to connect it just says remote connect no possible.


terra99

  • Newbie
  • *
  • Posts: 1
Re: Teamviewer 11 no unattended access without login first
« Reply #3 on: March 29, 2016, 09:18:27 AM »
Hi all

I have the same issue, any info on this?

thx

vacaloca

  • Newbie
  • *
  • Posts: 8
Re: Teamviewer 11 no unattended access without login first
« Reply #4 on: May 22, 2016, 11:16:29 AM »
I also noticed this on a new Ubuntu 16.04 system. The daemon is running, and I can even briefly see the computer go online in contact list from my Android phone, but the connection drops until the GUI window is open again.

It seems similar to this other post:
http://askubuntu.com/questions/765470/teamviewer-only-runs-when-gui-has-been-started

Any ideas on getting it working before logging into the system are welcome. =)

venik212

  • Newbie
  • *
  • Posts: 3
Re: Teamviewer 11 no unattended access without login first
« Reply #5 on: May 29, 2016, 02:08:40 AM »
I have the same problem, although I did not realize that the symptoms are like the ones described by the posters on this thread.  Local machine: Lubuntu 16.04 (with Cinnamon).  Remote machine: Mint 17.3 with Cinnamon.

Raz

  • Newbie
  • *
  • Posts: 1
Re: Teamviewer 11 no unattended access without login first
« Reply #6 on: June 28, 2016, 12:11:20 PM »
I found solution in case if anyone by google search come to this site.

On Teamviewer icon right click -> options
section General -> network settings-> wake on lan -> configure

attach it with your account with teamviewer.com

vacaloca

  • Newbie
  • *
  • Posts: 8
Re: Teamviewer 11 no unattended access without login first
« Reply #7 on: June 30, 2016, 10:24:38 PM »
I found solution in case if anyone by google search come to this site.

On Teamviewer icon right click -> options
section General -> network settings-> wake on lan -> configure

attach it with your account with teamviewer.com

I attempted this under Ubuntu 16.04, but it does not seem to make any difference. Running gnome-snell, not sure if that has anything to do with it. Definitely had it working before on a previous 14.04 installation.

phillynux

  • Newbie
  • *
  • Posts: 3
Re: Teamviewer 11 no unattended access without login first
« Reply #8 on: October 23, 2016, 07:20:55 AM »
Hello ,

I've the same Issue here , Since upgrade from teamviewer 10 to 11.
I'am on Mageia 4 Linux OS, with kde 4.14 and kdm as login program.

It seems to be a problem between teamviewerd daemon and X11  ( Xorg ) or Kdm.

When i read teamviewer logfile, i can see those messages which can explain why teamviewer does not detect
any "screen" when kdm is  displayed.

The logfile is located at : (var/log/teamviewer11 : redhat rpm version )
Here are the corresponding rows  :



Here the sequence when TV daemon detect an open session : 

2016/10/23 15:16:53.402 26753 4044032832 S   XSocket observer: removing XSession: 0
2016/10/23 15:16:53.402 26753 4044032832 S   XSocket observer: adding XSession: 0
2016/10/23 15:16:53.402 26753 4025482048 S   Updated sessions: [ 1000000  L root ] 
2016/10/23 15:16:53.402 26753 4025482048 S   UpdateOnlineState newOnlineValue 1
2016/10/23 15:16:53.402 26753 4025482048 S   systemd: skipping update of :0 (ID = c5) as session leader (pid = 2843) seems to be gone already
2016/10/23 15:16:53.402 26753 4025482048 S   Updated sessions: [ 0     ]  [ 1000000  L root ] 
2016/10/23 15:16:53.402 26753 4025482048 S   UpdateOnlineState newOnlineValue 1


Here the sequence when, the session is logged out and "KDM" is displayed.
TV daemon  doesn't detect any open session : 

2016/10/23 15:16:53.501 26753 3960458048 S   TerminalServer::SessionLogout for session 0
2016/10/23 15:17:13.758 26753 3960458048 S   TerminalServer: XServer respawned, but has no information attached
2016/10/23 15:17:13.758 26753 3960458048 S   systemd: skipping update of :0 (ID = c5) as session leader (pid = 2843) seems to be gone already
2016/10/23 15:17:13.758 26753 3960458048 S   TerminalServer: XSession did not reappear within 20000 ms, terminating session

An then the teamviewer machine isn't  seen "active" anymore on teamviewer interface.


I tried several modifications of kdm and Xserver config files ( Xorg), teamviewer configuration ( with unatended access, wol configured ... )
without any success.

Did anyone  here find  a solution ?


phillynux

  • Newbie
  • *
  • Posts: 3
Re: Teamviewer 11 no unattended access without login first
« Reply #9 on: October 24, 2016, 08:10:01 AM »
Hello again ,


those messages found in a teamviewer 9 version logfile seem  to show that it's a regression
between version 9/10 an version 11 :

2014/11/13 18:09:54.533  2033 4147418944 S0   systemd: no active session found for display :0, assuming login screen
2014/11/13 18:09:54.533  2033 4147418944 S0   systemd: no active session found for display :0, assuming login screen