Author Topic: Unable to connect to Windows due to version mismatch  (Read 3239 times)

fharju

  • Newbie
  • *
  • Posts: 1
Unable to connect to Windows due to version mismatch
« on: May 14, 2016, 06:24:30 AM »
Hello, on my Win system I have updated TeamViewer to the latest version as of today. I then installed the latest version on a Mac (9.0.43731) and it will not allow me to connect.

The error message on the mac is: Your partner uses a newer version of TeamViewer. You need to update TeamViewer to establish a connection.

On the Mac, when I check for updates it says I'm using the latest version.

How can I connect? Is there a way on the Windows PC to allow older versions of the client to connect?

Thank you

Danl

  • Full Member
  • ***
  • Posts: 131
Re: Unable to connect to Windows due to version mismatch
« Reply #1 on: May 14, 2016, 11:01:48 AM »
My understanding is that TV is downward compatible, but not upward compatible. The latest version is *not* v9.0.43731. For a PC at least, the latest version is v11.0.59518 and for Mac is v11.0.59131. v9 won't connect to v11, but v11 will connect to v9.

matt

  • Hero Member
  • *****
  • Posts: 904
Re: Unable to connect to Windows due to version mismatch
« Reply #2 on: May 14, 2016, 06:06:55 PM »
but v11 will connect to v9.
However v11 will NOT connect to v8 or earlier
(This backwards compatibility seems to have started with ver9

 

anything