Author Topic: Teamviewer will not load on startup  (Read 16409 times)

dragon91

  • Newbie
  • *
  • Posts: 2
Teamviewer will not load on startup
« on: January 30, 2014, 05:45:52 PM »
I installed Teamviewer host on 2 different computers. The computer I am trying to access will not load Teamviewer on startup at all. I followed instructions in the manual and selected the "start teamviewer with windows" box, but it doesn't work. The instructions said that I would be prompted to create a password, but nothing happened. I'm not sure what to do. I need to access my computer unattended while I am at work. I can't do that if teamviewer will not load on startup. I never had this problem with logmein. I really don't want to switch back to logmein. Can someone help me?

Admin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 448
Re: Teamviewer will not load on startup
« Reply #1 on: January 31, 2014, 04:00:34 AM »
can you access the system you want to log IN to?
on that system ,double click the teamviewer icon
in the windows that opens click:
extras/options/security

under "personal password" enter the password( twice that you want to use)

under "rules for connection to this computer" choose :"allowed for all users" from the drop down.
click "ok"
 under the general tab make sure it stays"start with windows"

close the teamviewer window.
Restart the system
see if it appears as available to connect
« Last Edit: January 31, 2014, 04:03:12 AM by Admin »

dragon91

  • Newbie
  • *
  • Posts: 2
Re: Teamviewer will not load on startup
« Reply #2 on: February 01, 2014, 12:11:41 PM »
I did all of that and nothing has changed. It still will not load with windows.  :'(

matt

  • Hero Member
  • *****
  • Posts: 904
Re: Teamviewer will not load on startup
« Reply #3 on: February 05, 2014, 04:11:50 PM »
On the machine that you wish to connect TO remotely

Open teamviewer > Connection >> setup unattended host

thegilley

  • Newbie
  • *
  • Posts: 1
Re: Teamviewer will not load on startup
« Reply #4 on: April 04, 2016, 09:20:10 AM »
Hi I stumbled upon this post as I was having difficulties with TeamViewer loading at startup as well.  I believe I may have a solution to this problem that I thought would be worth adding to the topic.

First, let me start off by saying I am running Windows 10 Pro on the system that I am seeing my issues with, the Home versions do not seem to be doing what I am having trouble with.  Additionally, I have tried reinstalling TeamViewer to reload the services with some success, however, it only lasts temporarily before I start having issues with TeamViewer not loading at startup.  I believe this may be something to do with Windows itself rather than the program, as this new version of Windows is supposed to be focus on security.  With this assumption, I believe every time Windows has a major patch, as I know there have been a few, it may possibly  be removing the service from it's startup causing the program to not load.  The solution that I would propose would be to add a registry entry that will force the program to load in the run Key.  To do this open regedit, go to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" Key and add a new string entry in the right side section.  Here is what I entered into the Edit string dialog:

Value name:
TeamViewer

Value data:
/min "C:\Program Files (x86)\TeamViewer\TeamViewer.exe"

Make sure to keep the quotation marks around the path.  Additionally you may need to edit the path name if you installed the program into a different folder.

I hope this helps, so far it is working for me, but I will know for sure after the next major update to Windows.

chrisleblanc_org

  • Newbie
  • *
  • Posts: 1
Re: Teamviewer will not load on startup
« Reply #5 on: June 07, 2016, 05:20:24 PM »
I tried this method and it didn't work for me.

I applied another method that I know.

You need to go into admin tools from control panel and find scheduled tasks. (or search for it in the cortana search box)

Create a new task and set it to run with highest privileges. Specify that it is to run whether you are logged in or not.

On the trigger tab, set it to At System Startup.

Under actions, put the path provided by thegilley.

On conditions, uncheck the start only if computer is on AC power in case you are using a laptop.

On settings, uncheck the stop if running longer than 3 days.

Save that and you will need to enter your password.

Reboot and try it out :). this gets around the UAC prompt.





oohansel

  • Newbie
  • *
  • Posts: 3
Re: Teamviewer will not load on startup
« Reply #6 on: June 08, 2016, 06:19:46 AM »
I tried this method and it didn't work for me.

I applied another method that I know.

You need to go into admin tools from control panel and find scheduled tasks. (or search for it in the cortana search box)

Create a new task and set it to run with highest privileges. Specify that it is to run whether you are logged in or not.

On the trigger tab, set it to At System Startup.

Under actions, put the path provided by thegilley.

On conditions, uncheck the start only if computer is on AC power in case you are using a laptop.

On settings, uncheck the stop if running longer than 3 days.

Save that and you will need to enter your password.

Reboot and try it out :). this gets around the UAC prompt.

Worked for me!
« Last Edit: June 08, 2016, 06:57:33 AM by oohansel »

oohansel

  • Newbie
  • *
  • Posts: 3
Re: Teamviewer will not load on startup
« Reply #7 on: June 08, 2016, 03:42:31 PM »
I tried this method and it didn't work for me.

I applied another method that I know.

You need to go into admin tools from control panel and find scheduled tasks. (or search for it in the cortana search box)

Create a new task and set it to run with highest privileges. Specify that it is to run whether you are logged in or not.

On the trigger tab, set it to At System Startup.

Under actions, put the path provided by thegilley.

On conditions, uncheck the start only if computer is on AC power in case you are using a laptop.

On settings, uncheck the stop if running longer than 3 days.

Save that and you will need to enter your password.

Reboot and try it out :). this gets around the UAC prompt.

Worked for me!

Correction, only worked twice.
This is still a problem

oohansel

  • Newbie
  • *
  • Posts: 3
Re: Teamviewer will not load on startup
« Reply #8 on: June 08, 2016, 04:57:23 PM »
And this only worked ONCE

You need to go into admin tools from control panel and find scheduled tasks.

Create a new task and set it to run with highest privileges. Specify that it is to run whether you are logged in or not.

On the trigger tab, set it to At System Startup.

Under actions, put the path "C:\Program Files (x86)\TeamViewer\TeamViewer_Desktop.exe" with quote marks

On conditions, uncheck the start only if computer is on AC power in case you are using a laptop.

On settings, uncheck the stop if running longer than 3 days.

Save that and you will need to enter your password.

Reboot, this gets around the UAC prompt.
« Last Edit: June 08, 2016, 05:07:43 PM by oohansel »

nvnohi

  • Newbie
  • *
  • Posts: 1
Re: Teamviewer will not load on startup
« Reply #9 on: September 07, 2016, 10:30:40 AM »
I got the host version to work in Windows 10 pro by dragging the TeamViewer icon into the startup folder.  Not sure if that'll work for others.  It also works prior to login (but then, mine did anyway... it just stopped working once someone logged in, hence above fix).

FYI:  Windows 10 startup is right-click start, run, shell:startup

phmjr

  • Newbie
  • *
  • Posts: 1
Re: Teamviewer will not load on startup
« Reply #10 on: December 10, 2016, 02:32:23 PM »
The task scheduler solution worked for me when using:

"C:\Program Files (x86)\TeamViewer\TeamViewer_Service.exe"


Using "Teamviewer.exe" does start the program, but still does not allow remote access. It also does not provide an icon in the system tray or taskbar.

I have several computers running Teamviewer on Windows 10 and this problem only occurred on one of them, A Toshiba Satellite laptop.
« Last Edit: December 10, 2016, 02:35:14 PM by phmjr »

2dallly

  • Newbie
  • *
  • Posts: 1
Re: Teamviewer will not load on startup
« Reply #11 on: January 12, 2017, 04:53:48 AM »
I tried this method and it didn't work for me.

I applied another method that I know.

You need to go into admin tools from control panel and find scheduled tasks. (or search for it in the cortana search box)

Create a new task and set it to run with highest privileges. Specify that it is to run whether you are logged in or not.

On the trigger tab, set it to At System Startup.

Under actions, put the path provided by thegilley.

On conditions, uncheck the start only if computer is on AC power in case you are using a laptop.

On settings, uncheck the stop if running longer than 3 days.

Save that and you will need to enter your password.

Reboot and try it out :). this gets around the UAC prompt.


this did not work for me, when I got to the save it comes up with an error... An error has occured for task teamviewer. Error message: User Account restriction error. the possible reasons are that blank passwords not allowed, or that a policy restriction has been enforced....

Windows 7 - TV 11 set up with passwords for remote access - start tv with windows ticked - password 6 characters - assigned to account - Grant account easy access - Windows logon "allowed for all users"..... and i do not have a password or user account to logon the to PC it boots straight into desktop