Author Topic: Remove the "sponsored Session" popup  (Read 341846 times)

petaara

  • Newbie
  • *
  • Posts: 4
Re: Remove the "sponsored Session" popup
« Reply #15 on: August 30, 2011, 01:35:37 PM »
didn't see an edit button

If you also want the main window minimized to tray, use this code

Code: [Select]
Local $tvHandle = 0
while True
$tvHandle = WinWaitActive("Sponsored session")
if Not ($tvHandle = 0) Then
Send("{Enter}")
WinClose("TeamViewer")
EndIf
WEnd

Admin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 456
Re: Remove the "sponsored Session" popup
« Reply #16 on: August 30, 2011, 02:00:41 PM »
what are we checking for at deviant art..a little more narrow of a search term would be great : )

petaara

  • Newbie
  • *
  • Posts: 4
Re: Remove the "sponsored Session" popup
« Reply #17 on: August 31, 2011, 07:29:41 AM »
That was just iconshttp://sacrificials.deviantart.com/art/TeamViewer-Icon-Version-2-97213383

Seems to be a problem using
Code: [Select]
WinClose("TeamViewer") on the machine you are connecting to.

If you connect a second time, tv will connect but not show the desktop window.

izogfif

  • Newbie
  • *
  • Posts: 12
Re: Remove the "sponsored Session" popup
« Reply #18 on: August 31, 2011, 07:45:44 AM »
That was just iconshttp://sacrificials.deviantart.com/art/TeamViewer-Icon-Version-2-97213383

Seems to be a problem using
Code: [Select]
WinClose("TeamViewer") on the machine you are connecting to.

If you connect a second time, tv will connect but not show the desktop window.
This part of code was meant to be used on the machine where you open TeamViewer session, not on the remote machine. Actually, the initial code may even be simplified down to 4 lines:
Code: [Select]
while True
WinWaitActive("Sponsored session")
Send("{Enter}")
WEnd

petaara

  • Newbie
  • *
  • Posts: 4
Re: Remove the "sponsored Session" popup
« Reply #19 on: August 31, 2011, 11:49:05 PM »
That works, tried to make a line that also closed the main window to tray after closing the pop up.
I use tv between a couple of computers so wanted one code.


Problem was with winclose or  @SW_HIDE in the loop running on the machine you connected to, it would not bring up the desktop window.

g1tf4c3

  • Newbie
  • *
  • Posts: 2
Re: Remove the "sponsored Session" popup
« Reply #20 on: September 26, 2011, 04:09:51 PM »
To anyone that isn't confident enough to compile a script, or any other reason they don't wanna do it that way there's a behaviour I've noticed

I don't know if the behaviour is the same on windows or mac, but this is what happens on my opensuse linux box using teamviewer 6

If I open teamviewer and log in to a partner machine, yeah I get the 'nag' screen when logging out, but if I log back in whilst still in the same linux session, i.e. without having logged out of my desktop or restarted the machine, the nag screen doesn't appear when disconnecting from a partner any more

In other words, I only see the nag screen on the first time I disconnect

So, in the OP's case & scenario, if whatever OS he uses exhibits the same behaviour, he could log into his pc from his laptop, disconnect from the pc, then log back in

This time if he started a video then logged out, the nag screen wouldn't appear.  Again that would be assuming his machine behaves the same way my opensuse box does


Not a very elegant or ideal solution but thought I'd throw it out there all the same, and there is another approach he could adopt

I also have a pc connected to the tv and I use a foolproof solution that guarantees I get nothing like any nag screens so I don't even have to worry about any kind of workarounds for them, what I do is this

To play a film, I remove myself from the sofa, walk the few yards across the room, start the film, then walk back over to the sofa and proceed to enjoy viewing it ... and I'm convinced the physical exercise involved does me some modicum of good ;)

vezycash

  • Newbie
  • *
  • Posts: 1
Re: Remove the "sponsored Session" popup
« Reply #21 on: November 29, 2011, 05:58:01 AM »
Thanks to the code the gentleman shared I was able to handle the nagscreen. The script sometimes does not work so I modified it and this one is guaranteed to work every single time

Local $tvHandle = 0
while True
   $tvHandle = WinWait("Sponsored session")         ;check if the nagscreen exists
   if Not ($tvHandle = 0) Then
      WinActivate ("Sponsored session")          ;activate the nagscreen
      sleep(20)                           ;just a slight delay to allow for slow computers
      Send("{Enter}")                        ;close it
   EndIf
WEnd


The admin here are nice guys
Cheers

tarpanet

  • Newbie
  • *
  • Posts: 9
Re: Remove the "sponsored Session" popup
« Reply #22 on: December 10, 2011, 11:27:16 AM »
Hi All,

I recently learned about TV, and tried it out less than a week ago.  I understand the reasoning behind the "Sponsor pop-up", but, as noted in some preceding posts, it can be technically, in the way.

I offer an alternative solution to the aforementioned "scripts", which is simple, elegant, and it has worked for me without issue.  I use a small program (around 300KB), by the name of "clickoff.exe".  Once installed, on the PC, and you are presented with the Sponsor pop-up, simply position the cursor over the OK button on the sponsor dialog, and press Ctrl+Alt+D (by default). The pop-up goes away, and does so from then on. Note, You'll want to change Hot-Key for clickoff on your local PC to something other than "Ctrl+Alt+D", so as not to be confused with the clickoff Hot-Key on the remote (or partner) PCs.  To change the Hot-Key, right click on the clickoff tray icon...  It says it's a 32bit app, but it works on my 64bit box just fine.  Here's the URL: http://www.johanneshuebner.com/en/clickoff.shtml

izogfif

  • Newbie
  • *
  • Posts: 12
Re: Remove the "sponsored Session" popup
« Reply #23 on: December 11, 2011, 07:35:07 AM »
Hi All,

I recently learned about TV, and tried it out less than a week ago.  I understand the reasoning behind the "Sponsor pop-up", but, as noted in some preceding posts, it can be technically, in the way.

I offer an alternative solution to the aforementioned "scripts", which is simple, elegant, and it has worked for me without issue.  I use a small program (around 300KB), by the name of "clickoff.exe".  Once installed, on the PC, and you are presented with the Sponsor pop-up, simply position the cursor over the OK button on the sponsor dialog, and press Ctrl+Alt+D (by default). The pop-up goes away, and does so from then on. Note, You'll want to change Hot-Key for clickoff on your local PC to something other than "Ctrl+Alt+D", so as not to be confused with the clickoff Hot-Key on the remote (or partner) PCs.  To change the Hot-Key, right click on the clickoff tray icon...  It says it's a 32bit app, but it works on my 64bit box just fine.  Here's the URL: http://www.johanneshuebner.com/en/clickoff.shtml

I already did post executable, too:
Or just run compiled AutoIt3 script:
http://filebeam.com/635e3c20f774796211466fe25686af29
And this compiled script does exactly what it was intended to do, no setup is required, just launch and forget. The only drawback about applications is that they can come from untrusted source, and AutoIt scripts are well know for being detected as badware by most anti-viruses. So... if you concern about security, you'd better compile the script by yourself to be sure that it does only what you think it does.

Xozum

  • Newbie
  • *
  • Posts: 1
Re: Remove the "sponsored Session" popup
« Reply #24 on: December 25, 2011, 09:25:00 PM »
Hello.

If PC and laptop are on the same lan, connect using their IPs, instead Teamviewer IDs. This way appears no popup.

Regards.


manWithPlan

  • Newbie
  • *
  • Posts: 1
Re: Remove the "sponsored Session" popup
« Reply #25 on: August 03, 2012, 05:16:17 PM »
Thanks to previous posts for the idea. I needed to use this on my media center (connecting from a laptop), so customised the script to work as follows:

  • Clears the "Sponsored session" nag screen
  • Minimises the TeamViewer window
  • Restores Windows Media Centre (if open)

Code: [Select]
while True
   If WinWait("Sponsored session")<>0 Then
WinActivate("Sponsored session")
Send("{Enter}")
WinMinimizeAll()
WinActivate("Windows Media Center")
   EndIf
WEnd

Hopefully this will be useful to other MCE users...

csmith665

  • Newbie
  • *
  • Posts: 5
Re: Remove the "sponsored Session" popup
« Reply #26 on: September 02, 2012, 08:37:55 PM »
I actually just got done making a similar script myself.  Although it was originally written for XBMC, I have added an edition for Media Center.  Check out my post on XBMC forums for the exe file.

http://forum.xbmc.org/showthread.php?tid=135746

turkeybaster42

  • Newbie
  • *
  • Posts: 3
Re: Remove the "sponsored Session" popup
« Reply #27 on: September 09, 2012, 10:17:16 PM »
Hrm..tweaked again, those still weren't working for me. The "Press OK" box went away, but the background "Teamviewer" window would stay in the foreground. I'm using this now to close both;

Quote
Local $tvHandle = 0
while True
   $tvHandle = WinWait("Sponsored session")         ;check if the nagscreen exists
   if Not ($tvHandle = 0) Then
      WinActivate ("Sponsored session")          ;activate the nagscreen
      sleep(20)                           ;just a slight delay to allow for slow computers
      Send("{Enter}")                        ;close it
     WinActivate ("Teamviewer")          ;MYCODE kill the tv window
     sleep(20)
     Send("!{F4}")
   EndIf
WEnd

Thanks to all for their code submissions.

gazthrak

  • Newbie
  • *
  • Posts: 1
Re: Remove the "sponsored Session" popup
« Reply #28 on: December 11, 2012, 05:39:29 PM »
This actually interests me because my company actually has licenses so we can connect to stations that we support nationwide. Per Teamviewer, while the computers in our office need licenses, the stations we are connecting to do not. However, when we get out, it gives the nag screen which I would like to get rid of. I haven't gotten an official response how to do that because we only have so many licenses as part of our key.

Any native TV suggestions that dont require running scripts on client computers?


datechnerd

  • Newbie
  • *
  • Posts: 1
Re: Remove the "sponsored Session" popup
« Reply #29 on: June 20, 2013, 07:08:40 PM »
To prevent Sponsored Session popup go into the registry edit "windows" + "r" regedit, and go to \HKEY_CLASSES_ROOT\TeamViewerSession\shell\open\command and delete the data.